Register | Sign In
Toggle Navigation
Loading...

"Am I Ready" checker for Worldspan (PCI DSS)

by Travelport

Am I ready checker will verify if your computer is PCI DSS compliant, alerting if upgrades required

Product Version: 1.1
License: Enterprise
Price: 0.00 USD
Keywords: PCI
Distribution Methods: Direct Download

New Free

Platform
Travelport Smartpoint

Host
Travelport Worldspan

Category
Custom Development / Consultancy

Regions Supported
Global

With fraud and hacking costing the industry an estimated $1bn annually and growing, the protection of your customer data security is paramount. Maintaining a set of security standards to combat this criminal activity is critical when dealing with customer credit card information. That is why the Payment Card Industry Data Security Standards (PCI DSS) have been developed. In its latest version, a more secure encryption protocol, Transportl Layer Security (TLS) 1.2 or higher, will be required in order to meet the PCI DSS compliance obligations from 30th June 2018.

IATA has also issued a resolution stating that any IATA agent that accepts card transactions against its own merchant agreement or issues Billing and Settlement Plan (BSP) card transactions will fall under the PCI DSS compliance obligations. It has stated that failure to comply with these by 01st March 2018 will result in the issuance of an administrative non-compliance and could lead to the removal of card as a form of payment.

Supporting you on your journey towards PCI DSS compliance

We each have responsibilities to ensure compliance of the new PCI DSS standard and IATA Resolution. Travelport is serious about data security, and will be fully PCI DSS compliant with the new protocol. You will need to ensure you're compliant prior to 01 March 2018 in order to be ready for the new security standards.

The Am I Ready checker allows you to verify your software versions to save time and frustration from having to look up version numbers. It verifies the following versions:
1) your operating system
2) Browser version and presence of TLS 1.2

The am I ready checker also verifies that the TLS protocol is working correctly.

You can run this utility as often as you want, and copy the results. You do not need to be signed into Worldspan to run this checker. You must be on a supported Operating system of Win 7 (SP1) or higher.

Have your Travelport Marketplace Administrator order the checker, then the rest of your office will be able to sign into Travelport Marketplace and download it.

Please see the User Guide for more information.

Key Product Features

  • FREE and FAST utility that checks for required versions for PCI DSS compliance
  • Checks to see if you meet the PCI DSS compliance minimum requirements for your workstation
  • Allows you to quickly check to see if the versions of software you are using are PCI DSS compliant
  • Verifies communication protocol TLS 1.2 is active